Aller au contenu


Photo
- - - - -

Export corrompu après synchro vidéo-audio

export synchro audio vidéo

  • Veuillez vous connecter pour répondre
5 réponses à ce sujet

#1 TECnaiche

TECnaiche

    Nouveau

  • Membres
  • Pip
  • 3 messages
  • Mac : Macbook Pro 15 2018
  • Version OS X : 10.14

Posté 13 octobre 2019 - 16:55

Salut à tous,

 

J'ai cherché tout le weekend en vain et cela fait 2 fois que j'ai le même souci et impossible de trouver de l'aide dessus. J'ai l'impression d'être le seul à avoir ce problème 😰. Pour info, je suis sur la dernière version de Final Cut Pro X.

Je vous explique : j'ai enregistré ma vidéo avec mon iPhone et le son avec un enregistreur son (Zoom H1). Je me retrouve donc avec mes rushs vidéo en format .mov sur mon iPhone et mes fichiers son que j'importe depuis mon enregistreur.

Il faut savoir qu'un fichier audio peut parfois correspondre à plusieurs plans vidéo étant donné que je n'arrête pas mon enregistreur entre chaque séquence vidéo que je tourne.

 

Je créé ma bibliothèque puis mon projet en Apple Pro RES 422 HQ et en 1080P en 60 fps (qui correspond au format vidéo d'origine de l'iPhone). Je créé ensuite mes nouveaux plans synchronisés sur l'audio en utilisant la fonction prévue à cet effet sur Final cut Pro (je garde d'ailleurs le format 1080p/60fps/Apple Pro RES 422 HQ sur ces nouveaux plans).

 

Après quelques plans synchronisés, j'exporte ma vidéo (en H.264) et sur ma vidéo, j'ai des images de plans déjà lus qui viennent parasiter les plans suivants (ça brouille un peu l'image, un peu comme l'effet Canal +). J'ai essayé de lire la vidéo sur Quicktime et VLC et le résultat est le même.

 

Je ne comprends vraiment pas comment résoudre ce problème et surtout si vous en avez déjà entendu parler. Je vous ai joint 2 images montrant la superposition de 2 plans différents lors de la lecture de la vidéo exportée. Surtout que ça peut apparaître plusieurs fois dans la vidéo.

 

Pour info, j'ai essayé de prendre les plans de l'iPhone sans créer de nouveaux plans synchronisés sur l'audio et j'ai l'impression de ne pas rencontrer ce souci. Est-ce que vous pensez que c'est parce qu'il rate la synchro sur l'audio de mes plans vidéo parce que j'ai des fichiers son trop long ? Ou est-ce que c'est autre chose ? Surtout que ça n'apparaît pas vraiment lors de la lecture de la timeline donc c'est d'autant plus énervant.

 

Merci beaucoup pour votre aide et excellente fin de weekend à tous.

 

Jérémy

Miniature(s) jointe(s)

  • Superposition plans 1.jpg
  • Superposition plans 2.jpg


#2 JLB21

JLB21

    Maître

  • Membres
  • PipPipPipPipPip
  • 1 582 messages
  • Gender:Male
  • Location:78
  • Mac : iMac i7 5K 4 GHz 24 Go CG 4 Go
  • Version OS X : 10.14

Posté 13 octobre 2019 - 18:05

Bonsoir,

 

Oui, je pense que c'est la synchro qui pose problème.

 

Tu n'es pas seul, tous ceux qui filment avec un iPhone ont des problèmes de synchro avec l'audio.

Car l'iPhone filme avec des fréquences d'images variable alors que ton audio est enregistré en dehors et en continu.

 

Pour filmer avec un iPhone et ne pas avoir d'ennuis, il faut utiliser Filmic Pro qui permet l'enregistrement en fréquence d'images fixes.

 

La bible de la capture vidéo avec un iPhone, c'est ici.

 

Juste un petit détail, pourquoi alourdir tes rendus avec du ProRes 422 HQ ? Le 422 ne suffit-il pas ?


Modifié par JLB21, 13 octobre 2019 - 18:33.


#3 TECnaiche

TECnaiche

    Nouveau

  • Membres
  • Pip
  • 3 messages
  • Mac : Macbook Pro 15 2018
  • Version OS X : 10.14

Posté 13 octobre 2019 - 18:55

Salut,

 

Merci, ça va m'éviter de devenir fou  :D . Pour les rendus, j'ai choisi ProRes 422 HQ tout simplement parce que je pensais que ça résoudrait le problème. J'utilise normalement du 422.

Merci encore pour ta réponse et c'est vraiment embêtant ce problème ! Ça m'a posé plusieurs soucis de montage de mes vidéos et j'ai même cru que c'était un problème lié à la carte graphique  :unsure: .

 

Je vais faire la synchro du son de manière manuelle. Ca me prendra plus de temps mais au moins, je n'aurai plus ce problème de synchronisation.



#4 Macgicien

Macgicien

    Nouveau

  • Membres
  • Pip
  • 16 messages

Posté 13 octobre 2019 - 21:12

Salut,
Je n'ai jamais utilisé une vidéo d'un iPhone pour faire de la synchro.

Mais si c'est réellement un problème de fréquence d'image variable, tu peux essayer de créer des fichiers optimisé pour tes rushs iPhone. Cela réglera peut-être le problème.
Attention, cela va prendre de la place.

Autre chose, est-ce que Final Cut est réglé pour faire les rendus automatiquement ?

#5 TECnaiche

TECnaiche

    Nouveau

  • Membres
  • Pip
  • 3 messages
  • Mac : Macbook Pro 15 2018
  • Version OS X : 10.14

Posté 14 octobre 2019 - 13:10

Salut,

 

Merci pour ton aide :). Vu que je ne fais pas souvent des vidéos avec l'iPhone, je peux faire créer des fichiers optimisés pour cette fois. J'ai quand même essayé finalement de convertir mes fichiers en mode framerate constant avec handbrake. Je vous dirai si ça a fonctionné ce soir.

 

Et oui, le rendu est configuré de manière automatique en arrière plan. Pourquoi cette question?



#6 Macgicien

Macgicien

    Nouveau

  • Membres
  • Pip
  • 16 messages

Posté 15 octobre 2019 - 16:27

Je viens de faire un test.
En effet, les vidéos venant d'un iPhone ont une cadence d'image par seconde variable.
En créant un fichier optimisé depuis Final Cut, le ProRes généré prend une cadence fixe.

Si ton problème vient bien d'une cadence variable, il sera corrigé.



Aussi étiqueté avec au moins un de ces mots-clés : export, synchro, audio, vidéo

1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)